Don't Miss


No Sound In Sony Hi-Fi Solved

By on July 15, 2020
sony hifi system repair

 

 

 

 

 

 

how to repair sony hifi

This Sony Hi-Fi System came in with the complaint of no sound but other features seems to be working fine. I took out my old speaker and connected it to the output jack  and there was still no sound. This means this no sound problem was not due to bad speakers.

All the setting  were good and even the volume already tuned to maximum and the sound refused to come. 

external speaker test

I opened the cover and head straight to the main board and made sure the dc voltages are present. In deed there were good DC voltages in the mainboard. I can check the audio IC dc supply voltage first but this article is to let you know about the procedure of troubleshooting. 

how to fix sony hifi

Next, I checked the DC supply voltage to the audio sound IC. Again the DC voltage were present.

In fact for this model I had replaced some audio ICs already and it worked fine.

sony audio ic replaced

I took my rework station and heat up the IC and removed it. 

smd rework on audio ic

I have some spare good ICs with me and I replaced it

sony audio ic no  sound

rework station to remove audio sound ic

After soldering the IC, I cleaned the audio IC with cleaning solution and powered up the unit. The sound came back as expected.

how  to clean ic

Conclusion. Assuming if after replaced the IC and still no sound then I have to check the incoming and outgoing signal waveform already.

suranga

This article was prepared for you by Suranga Bandara who owns an Electronics repair shop in Anuradapura, Sri Lanka.




Please give a support by clicking on the social buttons below. Your feedback on the post is welcome. Please leave it in the comments. If you have electronic repair articles to share with us, please contact us HERE.

P.S-  If you enjoyed reading the above article, click here to subscribe to my blog (free subscription). That way, you’ll never miss a post. You can also forward this website link to your friends and colleagues-thanks!

Note: You may check out his previous post in the below links:

https://jestineyong.com/stand-by-red-light-in-lcd-tv-repaired/

 

Likes(76)Dislikes(0)

8 Comments

  1. Parasuraman S

    July 15, 2020 at 9:37 pm

    Good work!

    Likes(4)Dislikes(0)
  2. Albert van Bemmelen

    July 16, 2020 at 12:26 am

    Good job of course! But seeing you have so many of those amplifier chips in stock something tells me that they fail many times. Which likely is no good advert for the manufacturer of those Audio sets?

    Likes(4)Dislikes(1)
  3. Boyd nyirenda

    July 16, 2020 at 3:56 am

    What could be the problem with the subwoofer with no display?

    Likes(1)Dislikes(0)
  4. Yogesh Panchal

    July 17, 2020 at 4:32 pm

    Good Job!
    Suranga.

    Likes(0)Dislikes(0)
  5. Humberto

    July 23, 2020 at 11:54 am

    Wo! You have a lot of these ICs.

    Likes(0)Dislikes(0)
  6. nader

    July 23, 2020 at 1:31 pm

    hi
    You are a good repairman.
    My question is how did you notice the IC failure?

    Likes(0)Dislikes(0)
    • Anil

      July 24, 2020 at 2:25 pm

      If the supply And audio signal both present And still no sound then it is bad amplifier IC.

      Likes(0)Dislikes(0)
  7. Raj

    July 28, 2020 at 12:06 pm

    Great.. thanks

    Likes(0)Dislikes(0)

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Free Report